Official Codex Discord Server

  1. Welcome to rpgcodex.net, a site dedicated to discussing computer based role-playing games in a free and open fashion. We're less strict than other forums, but please refer to the rules.

    "This message is awaiting moderator approval": All new users must pass through our moderation queue before they will be able to post normally. Until your account has "passed" your posts will only be visible to yourself (and moderators) until they are approved. Give us a week to get around to approving / deleting / ignoring your mundane opinion on crap before hassling us about it. Once you have passed the moderation period (think of it as a test), you will be able to post normally, just like all the other retards.
    Dismiss Notice

Grimoire - full screen mode

Discussion in 'Golden Era Games' started by Diggfinger, Sep 20, 2019.

  1. Diggfinger Cipher

    Diggfinger
    Joined:
    Jan 6, 2014
    Messages:
    851
    Location:
    Belgium
    Hey all,

    small - but annoying! - (micro) issue:

    Yesterday I hooked my laptop to an external monitor to enjoy Grimwah in it's full glory.

    Upon re-launching the game today, however, it only shows in 'windowed mode' (game covers 3/4 of screen, rest is black).
    - I've tried changing the settings: full-screen mode on/off, changing resolution from 1920x to 1320x etc.
    - Also changed my laptops resolution from 1920*1080 (recommended) to lower and back up.

    So far, nothing helps.

    Any ideas?

    Thanks!
     
    • Brofist Brofist x 1
    • Shit Shit x 1
    ^ Top  
  2. Zep Zepo Titties and Beer Patron Dumbfuck Repressed Homosexual

    Zep Zepo
    Joined:
    Mar 23, 2013
    Messages:
    5,187
    Divinity: Original Sin
    Find a better game that wasn't coded by a retarded monkey.

    Zep--
     
    • butthurt x 6
    • Funny x 5
    • rolleyes x 1
    • Thanks! x 1
    • Fabulously Optimistic x 1
    ^ Top  
  3. Horton Novice

    Horton
    Joined:
    Feb 22, 2019
    Messages:
    56
    set your desktop to 1024 x 768

    but......you have to have the regular stock settings in the game for that to work or you will get a black screen.

    delete the cfg file in grimoire folder to reset the settings, before you do it, or go in game and make sure scaling is off and windowed mode is off.
     
    ^ Top  
  4. Solanacean Educated

    Solanacean
    Joined:
    Sep 25, 2017
    Messages:
    39
    Sounds an awful lot like the recently identified issue with scaling going haywire when dpi virtualization kicks in. For now, try this workaround: right-click on the game's executable file (Grimoire.exe), select Properties, go to Compatibility tab, check Disable display scaling on high DPI settings, click Apply, then click OK.

    Show Spoiler
    [​IMG]
     
    Last edited: Sep 20, 2019
    ^ Top  
  5. Barbalos Learned

    Barbalos
    Joined:
    Jun 14, 2018
    Messages:
    197
    Check out the IntegerScaler app, it's perfect for stuff like this. I used either this or the app Lossless Scaling on Steam (can't recall which) and it works fine. Lossless Scaling costs a few bucks though so maybe try IntegerScaler and see if that works for you.

    http://tanalin.com/en/projects/integer-scaler/
     
    ^ Top  
  6. Diggfinger Cipher

    Diggfinger
    Joined:
    Jan 6, 2014
    Messages:
    851
    Location:
    Belgium
    Thanks guys!

    I solved by changing my resolution to 1024 -> changing to game's resolution to same and restarting the game.

    Then I changed my display settings back but the game still works with 1024.
     
    ^ Top  
  7. Lady Error █▓▒░ ░▒▓█ Patron Literally Hitler

    Lady Error
    Joined:
    Oct 14, 2012
    Messages:
    1,876,560
    Steam forum would be a better place to ask this, as Cleve is more likely to see it there.
     
    • Acknowledge this user's Agenda Acknowledge this user's Agenda x 1
    • Informative Informative x 1
    ^ Top  
  8. luj1 You're all shills

    luj1
    Joined:
    Jan 2, 2016
    Messages:
    3,957
    Location:
    Eastern block

    Solution to mouse problems - reduce mouse polling rate to 125 Hz in driver software

    Solution to improper scaling - set your launch options in steam properties for the game to -w1024 -h768
     
    • Brofist Brofist x 1
    ^ Top  
  9. Valky Arcane Manlet

    Valky
    Joined:
    Aug 22, 2016
    Messages:
    2,418
    Location:
    Trapped in a bioform
    To add to this. I tried checking the disable scaling on high dpi settings and that did not do anything for me. Didn't bother changing my screen resolution, keeping it at 1920x1080. Simply doing nothing more than setting compatibility mode for grimoire.exe to Windows XP Service Pack 3 immediately fixed it so that I got the full height of my screen scaled in game.

    However windowed mode does not appear to do anything when I select it. Not a big deal because I never play games windowed, but considering the black bars from the aspect ratio, there could be some benefit to having windowed mode work so you could fill the rest of the screen real estate.

    Edit:
    By changing my desktop resolution to 1024x768, Grimoire successfully uses the entire screen for display without any black bars, which appear if I use 1920x1080. It would be nice if Cleve could find a way to make this work for 1920x1080 to avoid having to change the resolution before starting the game.
     
    Last edited: Nov 4, 2019
    ^ Top  
  10. cvv Arcane Patron

    cvv
    Joined:
    Mar 30, 2013
    Messages:
    13,981
    necro

    I've tried this:

    but incredibly, the game automatically switches my resolution back to 1080p and then it only runs in the top left corner of the screen. I've been using this metod of lowering my resolution a lot for older games but I've never seen a game automatically changing it back. I've tried the "Disable scaling on high DPI" option, the Win XP compatibility option, the launch parameter in Steam but nothing helps. Game doesn't want to be run in 768p. I can't even change the resolution in the game Settings, it's stubbornly on 1080p.

    I wouldn't fiddle with this, running it fulscreen with scaling is fine but some of the text is way too tiny and I just wanted to see if I can improve that. Seems I can't.
     
    ^ Top  

As an Amazon Associate, rpgcodex.net earns from qualifying purchases.