Putting the 'role' back in role-playing games since 2002.
Donate to Codex
Good Old Games
  • Welcome to rpgcodex.net, a site dedicated to discussing computer based role-playing games in a free and open fashion. We're less strict than other forums, but please refer to the rules.

    "This message is awaiting moderator approval": All new users must pass through our moderation queue before they will be able to post normally. Until your account has "passed" your posts will only be visible to yourself (and moderators) until they are approved. Give us a week to get around to approving / deleting / ignoring your mundane opinion on crap before hassling us about it. Once you have passed the moderation period (think of it as a test), you will be able to post normally, just like all the other retards.

Decline The text editor deletes line breaks in the entire post when you press backspace. This is very gay.

Thac0

Time Mage
Patron
Joined
Apr 30, 2020
Messages
3,276
Location
Arborea
I'm very into cock and ball torture
On Firefox, if I write a longer text and want to insert line breaks with the enter key, pressing backspace once deletes all of them and turns my neat paragraphs back into one unformated blob.

Is this place reddit, where linebreaks are collapsed by shitty css? Fix immediatly pls.

Problem illustrated:

n58Yuzx.png
 

Pink Eye

Monk
Patron
Joined
Oct 10, 2019
Messages
5,331
Location
Space Refrigerator
I'm very into cock and ball torture
This is the first paragraph.

This is the second paragraph.

This is the third paragraph

(works fine on on my end. using firefox too)
 

Lazing Dirk

Arcane
Joined
Dec 12, 2016
Messages
1,865,327
Location
Shooting up your ride

I'm on Firefox and I have no idea how you've even got that style of editor. I thought there was some option to turn off the WYSIWYG editor or something but can see nothing of the sort in preferences or settings. For me the editor is blue (like the rest of the forum), it's got groups of 5, 3, and 6 buttons at the top, and doesn't say "Body (Edit summary)" on it anywhere. Is your account somehow using some old style? Maybe try a Ctrl+F5?
 

Thac0

Time Mage
Patron
Joined
Apr 30, 2020
Messages
3,276
Location
Arborea
I'm very into cock and ball torture

I'm on Firefox and I have no idea how you've even got that style of editor. I thought there was some option to turn off the WYSIWYG editor or something but can see nothing of the sort in preferences or settings. For me the editor is blue (like the rest of the forum), it's got groups of 5, 3, and 6 buttons at the top, and doesn't say "Body (Edit summary)" on it anywhere. Is your account somehow using some old style? Maybe try a Ctrl+F5?
No, this is just a random image I fetched from the internet to illustrate what happens to my paragraphs here.

I found some leads however, it is related to Twiglard's width fixes. It doesn't happen on default. I will play around with that some more.
 

Lazing Dirk

Arcane
Joined
Dec 12, 2016
Messages
1,865,327
Location
Shooting up your ride
No, this is just a random image I fetched from the internet to illustrate what happens to my paragraphs here.

I found some leads however, it is related to Twiglard's width fixes. It doesn't happen on default. I will play around with that some more.

Oh, I thought you'd just given 110% effort on a screenshot. Well, good luck I guess.
 

Thac0

Time Mage
Patron
Joined
Apr 30, 2020
Messages
3,276
Location
Arborea
I'm very into cock and ball torture
Ok I figured it out. I was making soft returns instead of hard returns (shift+enter instead of just enter)

For some reason whenever you press backspace in the new text editor you eliminate the last soft return placed, no matter where the cursor is. This rule does not apply to hard returns (just enter). I am not sure if this is intended or a quirk of xenforo, I have never seen it before in my other text editors.. But now that I know what it was I can just do hard returns instead of soft returns and the problem is gone.
 

thesheeep

Arcane
Patron
Joined
Mar 16, 2007
Messages
9,301
Location
Tampere, Finland
Codex 2012 Strap Yourselves In Serpent in the Staglands Dead State Divinity: Original Sin Torment: Tides of Numenera Codex USB, 2014 Shadorwun: Hong Kong Divinity: Original Sin 2 BattleTech Bubbles In Memoria A Beautifully Desolate Campaign Pillars of Eternity 2: Deadfire Pathfinder: Kingmaker [Steve gets a Kidney but I don't even get a tag.] Pathfinder: Kingmaker I'm very into cock and ball torture I helped put crap in Monomyth
I have the same problem (using Chrome).

Sometimes (but only sometimes, not on every backspace press), the last line return just vanishes.
Extremely weird.

Also Soft-Returns are the true gentleman's way.
They are one line, and exactly one line, high - not whatever height the style has set to be below a paragraph.
Full control. :obviously:
 
Last edited:

mediocrepoet

En français: poètemédiocre!
Patron
Joined
Sep 30, 2009
Messages
5,529
Location
Combatfag: Gold box / Pathfinder
Codex 2012 MCA Project: Eternity Divinity: Original Sin 2
A slightly different issue, but possibly close enough, it's seemed to me that when you're quoting and it's got a quote pyramid attached to it, the text editor is inconsistent about clearing out the user names. Sometimes it's just a matter of erasing the text and/or backspacing over the textbox, other times, they just sit there leading to the text appearing to be attributed to the wrong person (in the editor at least, no idea if it'd post like that).

It's a pain in my autistic ass. Not sure if there's an easy way to address that or if it's an editor side glitch where it's no longer WYSIWYG.
 

darkpatriot

Arcane
Joined
Mar 28, 2010
Messages
4,536
I get the same issue, but it is not consistent. Sometimes it happens, sometimes it doesn't. It is very very gay though. I only ever use the enter key to make my new lines. Maybe I accidentally have the shift still pressed from a previous capital letter (Constant struggles in the shoutbox has made my typing speed pretty fast). But I am pretty sure that isn't the case.

Because I have had certain posts where it keeps happening every singly time I press backspace, and I keep having to go back and re-hitting enter to add the line break back in, and I am sure I am not somehow accidentally hitting shift every time.

But it shouldn't be happening anyway, and it is very very gay, and this is the only time I have ever encountered this issue on the entire internet, and it has happened several times as I have typed this post, and I am definitely just using enter.

I do use a java script blocker (although I allow most of the scripts on the codex), but I wanted to mention it in case that is impacting it in some way.
 

darkpatriot

Arcane
Joined
Mar 28, 2010
Messages
4,536
A slightly different issue, but possibly close enough, it's seemed to me that when you're quoting and it's got a quote pyramid attached to it, the text editor is inconsistent about clearing out the user names. Sometimes it's just a matter of erasing the text and/or backspacing over the textbox, other times, they just sit there leading to the text appearing to be attributed to the wrong person (in the editor at least, no idea if it'd post like that).

It's a pain in my autistic ass. Not sure if there's an easy way to address that or if it's an editor side glitch where it's no longer WYSIWYG.

That is because it clears out the nested quotes but leaves the quote tags for some reason, when you use the reply button.

There is a workaround though. Toggle the BB code (the [] button towards the top right) to see those empty quote tags so you an delete them.

The backspace deleting previous line breaks is happening again in this post, btw. Gay.
 
Last edited:

As an Amazon Associate, rpgcodex.net earns from qualifying purchases.
Top Bottom